University of Southern California

Passwords You Need to Change due to the Heartbleed Bug

Posted on by mbordas

Many websites and online services, including Facebook, Instagram, Google, and Yahoo, were affected by the recently announced Heartbleed vulnerability. The site linked below has collected responses from social media, email, financial, and other companies regarding steps they have taken to address the vulnerability and recommendations about whether users should change their passwords.

The Heartbleed Hit List: The Passwords You Need to Change Right Now (http://mashable.com/2014/04/09/heartbleed-bug-websites-affected/)

Comments are closed.