University of Southern California

Author Archives: tzuchinc

March Security Updates

Posted on by tzuchinc

Microsoft Microsoft recently released nine critical updates for Windows, Office, Internet Explorer, Edge, and more. These updates correct vulnerabilities that could lead to remote code execution and allow malicious users to bypass Windows security features. Microsoft also released nine additional … Continue reading

Posted in Security Updates |

Privacy and Personal Assistant Devices

Posted on by tzuchinc

Voice-activated personal assistants such as Google Home, Amazon Echo, Apple’s Siri, and Microsoft’s Cortana are on the rise. While these smart devices bring convenience, they may also bring privacy concerns Continue reading

Posted in Mobile Devices, Privacy |

Recent Security Updates

Posted on by tzuchinc

Microsoft released five critical updates for Windows, Internet Explorer, Edge, and Office, as well as a critical update to protect Windows systems from a zero-day vulnerability in Adobe Flash Player. These updates address vulnerabilities that could lead to remote code execution. Continue reading

Posted in Patch Tuesday, Security Updates |

Zero-Day Vulnerability in Adobe Flash Player

Posted on by tzuchinc

Adobe recently released a security advisory to address a zero-day vulnerability affecting Flash Player. (Zero-day vulnerabilities are those that exploit previously unknown vulnerabilities and for which there is no available patch.) If successfully exploited, this vulnerability could allow an attacker to take control … Continue reading

Posted in Security Updates |

Recent Security Updates

Posted on by tzuchinc

Microsoft released six critical updates for Windows, Internet Explorer, and Edge. These updates address vulnerabilities that could lead to remote code execution. Continue reading

Posted in Patch Tuesday, Security Updates | Tagged , , , ,

Support Ended for Internet Explorer 8, 9, and 10

Posted on by tzuchinc

Microsoft has ended support for Internet Explorer (IE) versions 8, 9, and 10 as of January 12, 2016. ITS recommends that users of IE 8, 9, or 10 upgrade to a newer web browser. Continue reading

Posted in Security Updates |